Genesys Cloud Developer Forum

Renaming of a Predictive Engagement SDK command


We plan to rename the api.customer.get command in the Predictive Engagement SDK to api.customer.getData. To use the more correct terminology, we will also rename the visitCount variable in the response to sessionCount. This change will affect a small number of Predictive Engagement customers as it is an optional feature and is not routinely used.

Change Category


Change Context

We are renaming this to align better with other commands and prepare for the deprecation of the service that powers the old command.

Change Impact

We believe that we have identified all customers who are using this and we are working directly with them.

Date of Change

May 04, 2022

Impacted APIs

In the future, we will deprecate the public API endpoint used for the old command .



This topic was automatically closed 62 days after the last reply. New replies are no longer allowed.