Transfer to flow from agent script

Hi guys,

I am having some problem in a script that we have made, here I indicate:

We created a script with the function "Blind transfer" and we want to transfer this call to an inbound flow. To achieve this we do a "Blind transfer" in the address we are indicating the id of the flow to which we want to transfer and this works correctly.

However, I have created another button "Blind transfer" that points to another flowid different from the previous one and for this case it does not work, it indicates that the address is not valid.

I do not understand the difference in behavior, in the end it is the same functionality and the only thing that changes is the flowid.

Can you help us with this?

Thanks in advance.
Best regards.

Not sure about the FlowIds but usually we use flowname@localhost for calling a flow from within Genesysy.

and replace spaces with %20
Internal Transfer Flow becomes Internal%20Transfer%20Flow@localhost

This is for flows that are not secure flows, those you can select directly of course

Hi @Anton_Vroon

First of all thank you for your answer.

What I am doing is to create a button, that makes a blind transfer and in the address I write the flowid. When I write the flowid that you see in the following screenshot, it works correctly.


However, with the same script, if I change the flowid for another flow (also inbound flow) it does not work.


To give some more information, the error that is displayed when trying to make the transfer is the following:

Both flows are inbound and have no complexity, they simply play an audio and disconnect the call, so from my point of view it has nothing to do with the internal behavior of the flow and it has nothing to do with the script.

I hope you can help me!

Thanks in advance.
Best regards.

1 Like

Can you try the method I suggested eg

Just to see if you get the same error?
Its just another way of achieving the same thing.

If you place a new call directly to the flow that is generating the error, does it connect, again you can use the same method I provided when placing a new call in Genesys, eg

1 Like

Hi again @Anton_Vroon

I have done it as you indicated (nameflow + @localhost) and it worked correctly.

Additionally I have also tried to put the flowid + @localhost (3eb59604-31d5-42ed-9930-7e024b192e5e@localhost) and it also works correctly.

However, I still have the question why one flowid (without @localhost) works and another flowid (without @localhost) does not.

Thanks for your help in either case, it has been very helpful!

Best regards.

1 Like

No worries :slight_smile:

If it is working with the @local host but not without, and no other change made, sounds to me like something internal to Genesys networking/functions/APIs etc.

Hopefully someone from Genesys can answer that bit.

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.